fGIS - Revision History

Get fGIS now...click here


 

September 24, 2005 (executable dated September 13)

1.      Added the Utilities > Buffer dialog. Select a point, line or area object and create an area shapefile around it at a designated radius or width.

2.      Added SDTS layer support. The SDTS file format is often used to distribute vector or raster GIS data from the US Geological Survey.

3.      Added the Utilities > Generate Cruise Points dialog. Select an area object and fill it with either random or systematic points. The generated points are saved as a shapefile, which can be used in fGIS or transferred to a GPS unit for navigation. (Other GPS software such as DNR Garmin Tool or OziExplorer would be needed to upload the points to a GPS receiver.)

4.      Added WGS84 to Lat/Lon Location to WTM dialog.  WGS84 can also be used with the Live GPS Utility. (Note: The Lat/Lon Location to WTM utility is a "Go To" utility that works with WTM, UTM or WGS84 data. If requisite shapefile layers are loaded, it can also serve as a Public Land Survey System locator.)

5.      Added prompts before removing a layer or deleting a field.

6.      Added the Pan command to the view's right-mouse-click popup menu so that the view can be panned while editing.

7.      X and Y fields in point shapefile attribute tables now automatically update to 6 decimal places, rather than two (a significant change for those using Lat/Lon coordinates).

8.      Updated /fGIS/ini folder with more .ini files (PDF preview 28KB).

9.      Updated language.ini file.

10.  The Available Field Lists on the New Shapefile Field Manager are automatically saved to fGIS.ini (so they can be used whenever fGIS is used) when the Add Field List or Delete Field List buttons are pressed.  Because of this, the Save Field Lists button has been removed. 

11.  On the Shapefile Table dialog, the Field > Delete command has been moved to the Table > Delete Field command.

12.  White Legend checkbox removed from Map > Print > Print Map dialog as this is now the default option.

13.  Bug Fix: The Split Shape tool, Edit Points tool, New Shape tool, and Open Traverse Dialog buttons are now disabled until the Edit mode is initiated.  (These buttons were inadvertently enabled on start-up with the last update of fGIS.)

14.  Bug Fix: If the user clicked on the Cancel button when creating a new shapefile, the topmost layer in the Legend would become editable.

15.  Bug Fix: If the user pressed the Down Arrow key in the Shapefile Table dialog, a new record would be added to the table.  This is no longer possible.

July 23, 2005

1. Corrected "fGIS_Setup.exe" to include the new "ini" directory described in #9, below.

July 12, 2005

1. Incorporated the latest TatukGIS Developer Kernel changes. This improves editing and writing MIF, DXF, DLG & GML vector layers.

2. New MrSID library, only ttkMrSid4.dll is required for MrSID viewing.

3. Vertices are now displayed for the layer specified in the Snapping combo-box, while editing shapes.

4. JPEG2000 support added.

5. IMG file support added.

6. GML file support added.

7. Bug Fix: The Layer > Export Layer dialog would not add the proper file extension if exporting to MIF or DXF formats. MIF or DXF formats should now be exported properly.

8. Bug Fix: The join created by the Utilities > Join Access Table to Shapefile dialog was not being properly saved to the project file.

9. Added "/ini" directory with "ini" properties files created to be used in Wisconsin DNR Managed Forest Law (MFL) maps. Standard point, line and polygon display properties used for MFL maps can be loaded by making a layer active and using the function "Layer=>Load .ini".

10. Added "mfl_map_header_icons.doc", a Word map template that includes moveable map icons.

11. Added "landscape.tpl", a fGIS map composition template in landscape orientation.

June 28, 2005

1. Bug Fix: the Utilities > Join Access Table to Shapefile dialog would only allow the fields from the first table in the database to be used in the join.  Now any field from any table in the database can be used. 

2. Bug Fix: the Layer > Load .ini File command was not loading legend text properly.

3. The default installation directory for "fGIS_setup.exe" has been changed to "C:\DNRAPPS" to accommodate Wisconsin DNR users. If you prefer another location such as "Program Files", then type in an alternate folder name in the setup dialog.

4. Updated the Help file to suggest using HyperCube from the US Army Corps of Engineers for image warping and georeferencing in combination with fGIS.

May 10, 2005

1. Added the Utilities > Merge Shapefiles dialog. This dialog can be used to merge multiple shapefiles into a new one. All fields from all input layers will be included in the output shapefile.

2. The Map > New Layer command now includes the New Shapefile Field Manager dialog to retrieve default attribute table settings. These settings are stored in a file named fgis.ini that is stored in the same directory as fGIS.exe. The New Shapefile Field Manager dialog can also be accessed from the Utilities > New Shapefile Field Manager command. An example fGIS.ini file to be used with the New Shapefile Field Manager is included (open it in Notepad or other text editor).

3. Added the Utilities > Clip Shapefiles dialog. Use this dialog to clip line or polygon layers to the boundaries of a polygon layer.

Point layers can NOT be clipped using this dialog. To clip out point layers, select the points using the Map > Spatial Selection dialog, then create a new shapefile of the selected points using the Layer > Export Layer dialog.

4. Added the Utilities > Repath Project File dialog. This dialog is useful for modifying a project file after data, projects, or directories have been moved.

5. Added WMF export capability to the Map > Export View to Image dialog. Note that WMF graphics can only be exported at screen resolution. The vector layers in WMF images can be resized without loss of quality in drawing programs. WMF images are not georeferenced.

6. An Access table join (created via the Utilities > Join Access Table to Shapefile dialog) can be saved to and reloaded from the project file.

7. Addition in the Load Library Layer dialog: When a new Env file is selected with the Env > Set Env File command and the project is saved, the new Env file name will be saved to a file named fgis.ini and used as the default Env file.

In the Load Library Layer dialog, layer display names can be specified in a field named "Alias" in the layer table, however the names stored in a .ini file will take precedence.

8. Added the "Increase Output Feature Size by" functionality to the Map > Send Map to Word dialog.

9. Bug fix: the Edit > Paste Shape command did not work if there were no other shapes in the shapefile.

10. The Import XY Table to Shapefile dialog now adds the new shapefile to the view after creating it.

11. The Map > Print Map dialog now includes a "white legend" checkbox that changes the Legend to white so that the background of legend icons prints white.

12. Bug fix: The Layer > Load .ini File command would only load the first legend item. Now it should load all.

13. Added the Minimize Window checkbox to the Search dialog.

14. The Map > Set Default Data Directory command was added. This command will set the first directory that fGIS look to for data, rather than the fGIS installation directory.

15. Updated language.ini.

 

April 7, 2005

1. Added the Layer > Copy Selected Shape and Edit > Paste Shape commands (also available from the View's right-mouse-click popup menu) so that shapes can be copied from other layers to the layer being edited. Line objects can only be pasted into line layers, polygon objects into area layers, etc. The shape is copied in WKT (Well-Known Text) format so that users could create or edit a shape in a text editor and paste it directly into the layer. To see the format, copy the shape and paste into a text editor.

2. Added Chains to status bar when using the Measure tool. (Chains are a standard land survey measurement. One Chain = 66 feet; 80 Chains = 1 Mile)

3. Added the Map > Bookmarks command. Multiple named bookmarks can be utilized and saved to the project file.

4. Added all UTM zones to the Lat./Lon. to WTM (Wisconsin Transverse Mercator) form. UTM users can modify the language.ini to display "UTM" text instead of WTM, or to place their UTM zone at the top of the projection list. Also added two checkboxes to add "-" signs to the input coordinates to designate southern and western hemispheres. (Longitude should be set to negative for users in Wisconsin and elsewhere in the US.)

5. The WTM location to Lat./Lon. command (from the view's right-mouse-click popup menu) will now utilize whatever projection is selected in the Lat./Lon. to WTM form (WTM or any UTM zone). Again, UTM users can modify the language.ini to display "UTM" text instead of WTM, or to place their UTM zone at the top of the projection list.

6. Added the Search for Township/Range/Section dialog to the Utilities menu. Requires that an appropriate Public Land Survey System layer is loaded.

7. Added the Layer > Load .ini file command. This command enables layer properties saved to an .ini file to be used for another layer. Users could create a library of .ini files and load them as new layers are created.

8. Added the Map > Selection submenu. The Selection Color command allows the selection color to be changed. The Selection Transparency sets the transparency of the selection color. Both settings are saved to the project file.

9. Updated the Utilities > 3-D Viewing > Export View to 3-D dialog to only output four standard image widths. The 3-D viewer software does not operate properly unless the input image width has an even number of pixels. Also, the 3-D viewer software locks-up if the input image is too large.

10. Updated the Map > Export View to Image command to include a dialog and additional options. By increasing the output image size, multiple images in the view can be put into a mosaic. Output image size can also be increased if the view is intended for printing in a publication. Increasing the output feature size will increase the size of labels, points, and lines in the output image.

11. The Remove All and Load .ini File buttons were added to the Image Catalog utility.

12. The Import XY Text Table to Shapefile dialog can now convert tab-delimited text tables to shapefiles.

13. Bug fix: The Traverse dialog was incorrectly computing bearings when a N/S degrees E/W bearing was input.

14. Modified the Layer > Save Layer Properties to .ini File command to prompt for the .ini file location. The default location is the location of the layer. This makes it easier to create libraries of layer.ini files, or to create a layer.ini file for a file in a read-only directory.

15. Bug fix: The Map > Save Project As command would not function if the original project file was Read-only. This should make it easier to modify projects in Read-only directories or CDs.

16. Bug fix: The "Increase output feature size" listbox from the Export View to 3-D dialog wasn't working properly.

17. Created a dialog for the Map > Send Map to Word command.

18. Created a dialog for the Export Image tool.

19. Added the Utilities > Routing Utility: The Routing Utility will locate addresses (using the From text and the Find Address button) and find the best route between two addresses (using the Find Route button) in the Routing Layer. The Routing Layer is typically a Road shapefile based upon the US TIGER roads data. Such a layer is available in the State_Park.zip fGIS sample dataset and for WI from the DNR. See dialog for more help.

20. Added the ability to select a different env.txt file instead of the one in the /fgis directory using the Env > Set Env File command on the Load Library Layer dialog. The default env.txt file can also be set in the language.ini file.

21. The Load Library Layer dialog will now optionally load an .ini file specified in the INI_FILE field of the Layer Table. This field can use environment variables for the path.

22. Added the Utilities > Live GPS Utility. This utility will display the GPS location for a GPS receiver outputting NMEA format data connected to the COM port. The location can optionally be snapped to a line layer to correct for moving features. This utility has not been tested with moving GPS receivers. See the dialog for more help.

23. There is now a small "C" button on the Lat/Lon Location to WTM dialog that will convert the input Lat/Lon to/from DD, DM, or DMS.

24. Updated language.ini.

February 24, 2005

1. Reverted back to the previous shape digitizing mode, again by popular demand. When digitizing, the next vertex is added to the closest line segment, rather than connected to the previous vertex. Vertices can be added by clicking on a line segment. Vertices can be deleted by double-clicking on them. Holding down the <SHIFT> key and digitizing will attach the next vertex to the previous one.

2. Updated the DXF handling library. It should handle complex files better.

3. Changed the Map > Print Simple Map command to Map > Print Map. The new dialog includes the previous Simple Map as well as a Template Map printing section, page orientation, and printer setup functions. A template example is included (print.tpl) for advanced users who want to design their own. The template files can be edited in Notepad. (Wisconsin DNR foresters will receive additional print template files from the GIS specialist.)

4. The Map > Overview Map command was added. This displays the Overview Map view. Using the right-mouse-click popup menu on the Overview Map, a layer can be added and the extent box color can be changed. The extent box can be used to change the extent of the main map view by left-clicking and dragging in the Overview Map view. The contents of the Overview Map are also saved to the project file. The Overview Map can also be used in the template files (.tpl) used with the Map > Print Map command.

5. Added the 3-D Viewing submenu to the Utilities menu. The 3-D Viewing > Export View to 3-D command displays a dialog that will export a DTM to a TIFF and the view to a BMP so that they can be viewed in a 3-D viewer program. The 3-D Viewing > Launch 3-D Viewer command will launch the utility. Note: This feature is in a beta stage and may not work consistently.
The 3D viewer (©Geomantics Ltd.) is distributed with Forestry GIS under license to the Wisconsin Department of Natural Resources - Division of Forestry.

6. Updated the Traverse tool to utilize N S E W directions.

7. Added Miles to the Traverse dialog for fire lookout tower shots.

8. Added the Hyperlink tool to the Utilities menu. This tool changes the function of the Pick tool to display the file specified by the filename in the Hyperlink field for the shape selected. Images, text documents, web pages, etc. can be used.

9. Bug fix: the quarter-quarter description generated by the Lat./Lon. Location to WTM dialog was reversed.

10. Changed the Measure tool graphic to Red.

11. The Measure tool now displays the distance from the beginning of the measured line to the cursor location.

12. Updated language.ini.

January 27, 2005

  1. The default digitizing mode has changed. The more intuitive "follow" mode is now available without having to hold down the shift key.  If you hold down the shift key when digitizing, the next vertex will be inserted into the nearest line or polygon segment.

  2. The Hide command was added to the Layer menu and the Legend popup menu.  This will merely hide the layer from the legend so that it does not take up so much space (for multiple base images, etc.). This setting is saved to the project file.

  3. The Unhide All Layers command was added to the Map menu.

  4. All image layers are added to the bottom of the layer stack.

  5. Right-mouse clicking on the legend now selects the layer under the mouse cursor, and then displays the popup menu.

  6. The display coordinates on the lower status bar display more decimal places if decimal degree data are being used.

  7. The status bar turns red when editing a shapefile.

  8. New splash screen in About box.

  9. By popular demand, the legend remains enabled when a shapefile is being edited.

  10. Added Help box for the Traverse dialog.

  11. The Add Point button on the Traverse dialog will now add a new point to a point shapefile relative to the point currently selected with the Edit Points tool (i.e., the Traverse Tool now works for point, line and polygon objects).

  12. Added support for ESRI Grid files (*.adf). This is the DEM format used by Wisconsin DNR.  These can be colored nicely using the Wizard button on the Layer Properties dialog.

  13. Projects should load faster, because the view goes directly to the saved extent, rather than the full extent first.

  14. The Image Catalog Utility dialog (Utilities > Image Catalog Utility) will load all layers in an image catalog and optionally hide them all upon loading. The DNR uses image catalogs to load groups of DRGs. There are also commands to Turn On/Off and Hide/Unhide all image layers as a group.

  15. Rods and Chains have been added to the Traverse window.

  16. DMS added to Lat/Lon Location to WTM dialog.

  17. The Sort Shapefile button was added to the Join Access Table to Shapefile dialog. 

    1. This function will sort the selected shapefile by the selected attribute field and output it to a new shapefile. The new, sorted shapefile should be added to the theme (legend or table of contents) in order to take advantage of it for the Access table join in (b).

    2. Access table records are now sorted by the join field prior to creating the join.  The join works best if there is a one-to-one relationship between the records in the shapefile and the Access table, AND if the records in each dataset are sorted by the same field.

  18. "Table > Add Field" and "Field > Delete" commands were added to the Shapefile Table dialog. (You can also add or delete attribute table fields with the Attributes Tool while in the Edit mode.)

  19. Updated the language.ini file.

January 12, 2005

  1. Added the utility "Import XY Text Table to Shapefile". This command will create a point shapefile from a comma delimited text table with XY coordinates in decimal degree format.

  2. Added the utility "Join Access Table to Shapefile". The Join is a "live" join to the database. The joined fields are visible in the Layer Properties, Attributes Tool, and Search dialogs.

  3. The fGIS help is now in CHM format rather than HTML.

  4. Bug fix: If a layer was removed from the view and there was no selected layer in the legend/table of contents, an error occurred when the user right-mouse clicked in the view.

  5. Measure Tool dialog box text corrected for "Length".

  6. The Lat/Lon Location to WTM dialog is now minimized before it places a graphic dot on the view so that it does not completely cover the graphic dot.

  7. Updated the language.ini file.

January 2, 2005

  1. Updated the Help System for revisions made to date. (FYI: Significant additions/changes to fGIS are anticipated in the first quarter of 2005. Plans include simplified print layout and 3D viewing capabilities among other features under development.)

fGIS Help Index     top     home
- Copyright © 2007-2011 ForestPal.com -
Web Statistics